wp_mp_templates table not generated in WordPress 4.2.2

This topic is: not resolved
Viewing 6 posts - 1 through 6 (of 6 total)
Author Posts
June 9, 2015 at 11:10 am #3661
multipliertech
Post count: 13

I’m having this issue where the wp_mp_templates table is not being generated on WordPress 4.2.2.

It works just fine in 4.1.1

Is this a bug?

June 9, 2015 at 3:11 pm #3662
traversal
Post count: 207

Hmmm, that’s a strange one. Is that happening when installing from a clean install? I’ll try to recreate, but it seems a bit odd it would only be that table, as the code doesn’t differ from other table creation statements.

June 10, 2015 at 2:02 pm #3663
multipliertech
Post count: 13

Yeah I tested it on a clean install, both versions, locally. I find it very weird, I have not done anything differently.

June 25, 2015 at 5:22 pm #3673
multipliertech
Post count: 13

This is the error I’m getting when activating the plugin.

WordPress database error: [Specified key was too long; max key length is 767 bytes]

CREATE TABLE wp_mp_templates (
id varchar(255),
supports text,
visibility text,
PRIMARY KEY (id)
) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci

Only happens in version 4.2+

Could it be my database charset setting? Can you please advise me on what I should do?

Thank you.

June 25, 2015 at 6:06 pm #3676
traversal
Post count: 207

Hi, sorry about this, it looks like this is relevant, which I admit I wasn’t aware of:

https://make.wordpress.org/core/2015/04/02/the-utf8mb4-upgrade/

I’ve just pushed a new beta release which should get around this issue. I would really appreciate it if you could give it a shot and let me know if it is now working.

https://www.masterpressplugin.com/support/downloads

Thanks for your patience.

June 26, 2015 at 8:53 am #3677
multipliertech
Post count: 13

Yes this works now. Thank you very much for your quick response.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Latest From the Blog

MasterPress 1.3.6 is now available

Masterpress 1.3.6 is a compatibility release. It resolves an edge case with shared fieldsets not working for MySQL 8 when the fieldset is limited to more than 1 post type or taxonomy or excluding any post types or taxonomies.

Plugin Requirements

MasterPress requires a minimum of WordPress version 4.9, MySQL 5.6, and PHP version 5.6.20.

We also recommend that PHP is configured to use a memory limit of 64MB per request (128MB may be required for sites with higher complexity).

This plug-in is not compatible with the WordPress.com hosted service.

Three AM