Contact Us

Please fill out the form below and we will get in touch with you shortly.

Latest From the Blog

MasterPress 1.1.5 now available

MasterPress 1.1.5 is now available. This release contains 2 very important compatibility fixes; PHP7 and WordPress 5. We have also:  Fixed hardcoded http link to Google Maps JS (replaced with https)Added new “Google Maps API Key” field to Settings > MasterPressFixed Visual/HTML Editor tab JS bug Please install this update as soon as you can… 

Plugin Requirements

MasterPress requires a minimum of WordPress version 4.9, MySQL 5.6, and PHP version 5.6.20.

We also recommend that PHP is configured to use a memory limit of 64MB per request (128MB may be required for sites with higher complexity).

This plug-in is not compatible with the WordPress.com hosted service.

Three AM