Disable Access to the Masterplan by User Role

This topic is: resolved
Viewing 2 posts - 1 through 2 (of 2 total)
Author Posts
March 7, 2013 at 1:05 pm #3009


I have setup a new User Role called Manager that I want to give close to full access to my new Post Types I have setup, Posts, Media, Pages and that is about all. I do not want the Manager User Role to be able to see and configure anything in Masterplan and so have been un-checking the manage_options box which successfully removes access to Masterplan.

The issue I am having is that when I log in as a Manager…

When I go to edit an entry under a Custom Post Type, the fields all have the padlock icon with the “You do not have permission to edit this field” on hover. I can however edit those fields.
When I go to add an entry under a Custom Post Type (Product Lists), the fields are not displaying at all, except for Title and slug.

The permission on the Post Type and fields are all set to Post Style and None (always editable), although they were previously set to be specific when I was testing earlier.

If I then change that User Role back to have the the manage_options box checked, I seem to get the behaviour I am after, but of course, the Masterplan access is back for the User Role.

So, I guess I am looking for the correct way to disable access to the Masterplan panel in admin, without messing with the Custom Post Type permissions.

Any suggestions greatly appreciated.

March 8, 2013 at 5:59 pm #3011
Post count: 207

Hey Sean.

I’ll have to take a look at that specific scenario, since something is definitely not quite right there for those field permissions.

In the meantime though, there might be one way out. If you head into Settings -> MasterPress, there’s a “MasterPress capabilities” panel, with two radio buttons representing capability modes:

Standard: which simply uses “manage_options” for everything, and

Specific: which allows more fine-grained control over the capability keys used to block access to various sections of the Masterplan.

If you check Specific, and check (or leave checked) the “On save, add capabilities above to roles with the manage_options capability” and update, what you should then find is that when you edit the Manager user role (via User Roles in under Masterplan) you’ll see a tab for “MasterPress” under capabilities now, which will allow you to disable access to MasterPress in a more granular way.

If you do it this way, it should hopefully solve the other problem too, but let us know if it doesn’t.

I will look into the issue when using “manage_options” as soon as I can.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Latest From the Blog

MasterPress 1.4.0 is now available

6th May 2024

This release has a focus on improving compatibility with PHP 8.2. The introduction of inheritance validation to PHP produced a lot of warnings when using MasterPress with PHP 8.2. I have updated most of the problematic code – but some code would have broken in previous PHP versions, so I have temporarily disabled inheritance validation… 

Plugin Requirements

MasterPress requires a minimum of WordPress version 4.9, MySQL 5.6, and PHP version 5.6.20.

We also recommend that PHP is configured to use a memory limit of 64MB per request (128MB may be required for sites with higher complexity).

This plug-in is not compatible with the WordPress.com hosted service.

Three AM