automatic updates not working

This topic is: not resolved
Viewing 6 posts - 1 through 6 (of 6 total)
Author Posts
March 29, 2021 at 9:38 am #4194
Christopher Sales
Post count: 4

Hi,

A client of ours has this plugin and we have purchased a license key for their copy. When we try to save the license key in Settings > Masterpress it loads and loads and says its valid, but then we save and navigate away from the page, the license disappears. This means that we cannot enable automatic updates and cannot update it through the wordpress website.

Can you please help?

Thanks
Nicole

March 29, 2021 at 9:48 am #4196
Jayme [MasterPress Support]
Post count: 14

Hi Nicole,

Can you please send through the Support Info under Settings > MasterPress?

Cheers,
Jayme

March 29, 2021 at 1:18 pm #4199
Christopher Sales
Post count: 4

Hi I’ve sent the information twice but I can’t see it appearing in the reply to this forum, do you have an email I can send it directly to?

Thanks

March 30, 2021 at 11:53 am #4200
Jayme [MasterPress Support]
Post count: 14

Hi Nicole,

Sorry for the late reply. You can either send to support@masterpress.com or upload to Pastebin and paste the link here.

Cheers,
Jayme

March 30, 2021 at 1:08 pm #4201
Christopher Sales
Post count: 4

Hi Jayme,
Here it is https://pastebin.com/bFdXmqLG

Thanks

March 31, 2021 at 7:01 am #4202
Jayme [MasterPress Support]
Post count: 14

Thanks for that. I have attempted to replicate the problem in an environment similar to your site, but haven’t found anything that would lead to the issue you’re having.

After reviewing the code I’m fairly confused as to why it wouldn’t be updating, it should save the licence regardless of whether it’s valid or not and it uses the default WordPress methods of saving options.

If you attempt to change other site settings, do they experience the same issue? eg. if you try to change the site tagline.

If not, would you be able to make a temporary admin account using my email address please?

Cheers,
Jayme

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Latest From the Blog

MasterPress 1.3.6 is now available

Masterpress 1.3.6 is a compatibility release. It resolves an edge case with shared fieldsets not working for MySQL 8 when the fieldset is limited to more than 1 post type or taxonomy or excluding any post types or taxonomies.

Plugin Requirements

MasterPress requires a minimum of WordPress version 4.9, MySQL 5.6, and PHP version 5.6.20.

We also recommend that PHP is configured to use a memory limit of 64MB per request (128MB may be required for sites with higher complexity).

This plug-in is not compatible with the WordPress.com hosted service.

Three AM