1.0.1 Beta 5 PHP Warnings

This topic is: resolved

Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
Author Posts
July 16, 2013 at 12:44 pm #3281
OM4
Post count: 13

During the MasterPress install process, I’m getting the following errors:

Non-static method MPU::combine_type_styles() should not be called statically
Non-static method MPU::combine_type_scripts() should not be called statically

Error Number 2048 (E_STRICT)

Line 3467/3468 in masterpress.php.

July 16, 2013 at 12:54 pm #3282
OM4
Post count: 13

Another issue I noticed during the install/upgrade process, because your table definitions in MasterPress::install() use boolean column definitions, dbDelta() executes unnecessary ALTER statements:

http://pastebin.com/FfBhJyNw

Instead of using boolean, it is better to use tinyint(1). See http://core.trac.wordpress.org/ticket/20634 for details.

July 20, 2013 at 10:24 am #3283
traversal
Post count: 207

Sorry about those issues, I’ll take a look ASAP. Thanks heaps for the tip about tinyint as well. dbDelta is a bit painful to work with in general, with its sometimes-bizarre syntax requirements.

  • This reply was modified 8 years, 2 months ago by traversal.
July 22, 2013 at 8:51 am #3285
OM4
Post count: 13

No worries Trav.

dbDelta() is definitely pretty picky about it’s SQL format!

August 14, 2013 at 2:07 pm #3304
OM4
Post count: 13

Hi Trav, is there any chance these issues could be fixed before 1.0.1 final is released?

They’re relatively minor syntax errors, and I’ve just looked at beta 7 and these issues still exist.

Thanks.

August 14, 2013 at 2:36 pm #3305
traversal
Post count: 207

Yep, will do.

August 14, 2013 at 8:12 pm #3308
traversal
Post count: 207

These two issues are now fixed in 1.0.1.b8. Thanks again for the bug reports 🙂

August 15, 2013 at 10:27 am #3309
OM4
Post count: 13

Thanks Trav, looks good.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Latest From the Blog

MasterPress 1.3.1 is now available

MasterPress 1.3.1 is a compatibility release for PHP 8 and WordPress 5.7. It still remains backwards compatible with older PHP versions.

Plugin Requirements

MasterPress requires a minimum of WordPress version 4.9, MySQL 5.6, and PHP version 5.6.20.

We also recommend that PHP is configured to use a memory limit of 64MB per request (128MB may be required for sites with higher complexity).

This plug-in is not compatible with the WordPress.com hosted service.

Three AM